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License Agreement
This Software, GIFConverter, is licensed, not 
sold, and may only be used under the terms out-
lined below.

License

Under this license, you may use the Software un-
der the following conditions:

• This software may be used for up to 15 days for 
evaluation purposes. After 15 days, you must 
either (1) register this Software under the terms 
noted in the Shareware Notification, or (2) de-
stroy all copies of this Software in your posses-
sion.

• You may use the Software on a single CPU at 
one time that is not used as a server. Each CPU 
on which GIFConverter is installed requires a 
separate copy and license. You may use a sin-
gle copy of GIFConverter on up to two com-
puters provided that such use is not concurrent 
and is by the same user.

• The Software may not be placed on a served 
disk unless enough licenses have been pur-
chased to cover the number of CPUs connected 
to the served disk.

• You may make one copy of the Software for 
backup purposes.

• The Software may be transferred to another 
party provided that (1) the manual and ALL 
copies of the Software are transferred to the 
new owner, and (2) the original owner notifies 
the author in writing of the change in owner-
ship. Upon transfer, the original owner must 
destroy all copies of the Software.

• This Software may be distributed for evalua-
tion as outlined in “Distribution” below.

Limitations

• This Software contains trade secrets, and you 
may NOT reverse engineer the Software in any 
way including disassembly or decompilation.  
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You may not use this software as the basis for 
any derivative work without the permission of 
the author.

• You may NOT resell this Software at a profit, 
nor may you rent this Software.

Termination

This license is automatically terminated upon 
breach of any of the terms of this license.  Upon 
termination, all copies of this Software and the 
documentation must be destroyed.

Warranty

This Software is sold “as is” under the terms of the 
Warranty listed below.

General

The purchaser, by agreeing to this license, affirms 
that the software will not be used, sold, trans-
ferred, or exported in any form contrary to the 
laws of the United States of America or the laws 
of any State.  The author assumes no liability for 
purchaser’s use of this Software resulting in the 
violation of a law.

Warranty
This Warranty gives you specific legal rights. You 
may have other rights, which vary from state to 
state.

Limited Warranty on Media

Media on which the Software is distributed by 
Kevin A. Mitchell is warranted against defects in 
materials or workmanship for ninety (90) days 
from the date of purchase.  If the media should 
prove defective, return it to the address listed 
above for replacement.

Disclaimer of Warranty on Software

This software and manual are sold “as is” and 
without any warranty, express or implied, includ-
ing but not limited to non-infringement of third 
party rights, performance or merchantability.

This program is sold without any express or im-
plied warranties whatsoever. Because of the di-
versity of conditions and hardware under which 
this program may be used, no warranty of fitness 
for a particular purpose is offered. The user is ad-
vised to test the program thoroughly before rely-
ing on it. The user must assume the entire risk of 
using the program. The author will assume no lia-
bility for any direct, indirect, incidental or conse-
quential damages resulting from the use of this 
software, including loss or interruption of busi-
ness, accidental loss of data, or damage to com-
puter equipment, or for any claim by a third party.

The author does not guarantee that this Software 
will work in every environment.  Specifically, no 
guarantee is made about the performance of the 
Software under a network, served disk, or multi-
user system.  This Software is not guaranteed to 
work on Macintosh-compatible computers not 
manufactured by Apple Computer, Inc., or on 
Macintosh computers that did not exist at the time 
the program was written. It is not guaranteed to 
work in the presence of INITs, system extensions, 
or other software which modifies the operating 
system, system traps, or other portions of the soft-
ware as provided by Apple Computer.

Distribution

GIFConverter is a shareware program. Shareware 
offers the opportunity to try out a fully-functional 
copy of a program before purchase. Although 
GIFConverter is freely available, it is a copyright-
ed program, and use or distribution in violation of 
the License Agreement and Distribution guide-
lines is against the law.

You may use GIFConverter for up to 15 days be-
fore registering it. GIFConverter is fully function-
al, and all features are present even without 
registration. The key you get when you register 
will disable the registration screen at startup time.

You may give copies of GIFConverter to your 
friends for evaluation. GIFConverter may be 
placed on BBSes and online service providers 
(such as CompuServe, GEnie and America On-
line) provided that the GIFConverter package is 
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downloadable without charge beyond normal 
connect charges. GIFConverter may be placed 
onto diskettes distributed by user groups at nomi-
nal fee.

When distributing GIFConverter, please give the 
complete contents of the disk, or the program ar-
chive and one of the documentation archives, 
making sure that you transfer all note files as well.

Vendors desiring to place GIFConverter into their 
catalogs must contact the author at the address on 
the cover requesting permission to distribute this 
program, and outlining their fees and shareware 
policies.

Whenever GIFConverter appears on a catalog, 
diskette, BBS, or online service, it must be identi-
fied as shareware. Vendors and operators must 
make it clear that online charges or disk fees have 
not paid for the use of this shareware product, and 
that additional payment is due the author.

Support
I offer support to my registered users on the GIF-
Converter program through any of the US Mail or 
electronic addresses listed on the cover. If you 
have a feature request, or if you find a bug in the 
program, do not hesitate to contact me. In general, 
I respond within about two business days.

From time to time, I will release new versions of 
GIFConverter and updated documentation. I dis-
tribute programs and documentation  primarily 
through electronic channels; if you have already 
paid for GIFConverter, you may download new 
versions of the program and machine-readable 
documentation without further charge. Replace-
ment disks and manuals are available for a fee 
plus shipping charges as stated in documentation 
accompanying the program. In general, it is 
cheaper to download new versions.

One place where I distribute GIFConverter is  LIB 
3 of the Graphics Support Forum on CompuServe 
(GO GRAPHSUPPORT). Here you will also find 
graphics conversion experts representing a wide 
range of computer models. This is an excellent 
place to obtain help in moving graphics between 
different computer models.. 

I also offer support through a Direct Connect fold-
er on the Macintosh Graphics & CAD (keyword: 
mgr) forum on America Online. When you get to 
Graphics & CAD, open the Direct Connect folder, 
then the GIFConverter folder. There you will find 
files containing new GIFConverter program and 
documentation files as well as a message base for 
support.

Internet users can find GIFConverter in the Info-
Mac archives. Use anonymous FTP to connect to 
sumex-aim.stanford.edu. Send E-mail requesting 
support to kam@mcs.net.
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About GIFConverter and GIF files

GIFConverter is a shareware graphics utility that enables you to work with raster images. These are the 
kinds of images you would use with a black and white or color paint application, or that you get from your 
scanner. Using GIFConverter, you can view these images, change their appearance, save them in nine dif-
ferent file formats, and print them.

GIFConverter was originally developed in response to a challenge by Larry Wood, administrator of the 
Graphics Support Forum on CompuServe. He was looking for somebody to develop an application for the 
Macintosh that supported GIF, the Graphics Interchange Format. (“GIF” is officially pronounced “JIF,” 
like the peanut butter. “GIFConverter” has a hard “g” as in “gift” because I named it before I ever heard 
the word GIF spoken.) You can use GIF files on practically any computer, and for that reason you will see 
thousands of GIF files on BBSes and major online services like Compuserve, GEnie, and America Online.

Images

GIF Files themselves can contain one or more images, each with an associated color map. An image is one 
way a computer can represent a picture. Images are more like photographs than like line drawings. Line 
drawings are made up of mathematical elements like lines, circles, curves and polygons. An image is made 
up of a rectangular arrangement of points.

Pixels

These points in the images are called pixels. “Pixel” is verbal shorthand for “picture element.” The image 
is actually a rectangular array of pixels. Think of a sheet of graph paper. You can color each square on the 
graph paper so that each square is one color. If you stand back from the graph paper, you don’t see the 
individual squares, you see the overall effect. On your computer screen, each pixel is 1/72” of an inch (or 
so) on a side. There are 5,184 pixels in every square inch of the screen. A 9” 512 x 342 pixel Macintosh 
screen has 21,888 pixels. A 13” 640 x 480 pixel Macintosh screen has 307,200 pixels.

Dots Per Inch

You may have a 300 dpi printer. The dpi stands for “dots per inch,” and a dot is just another name for a 
pixel. These printers have 90,000 pixels per square inch. 

Bits Per Pixel

GIFConverter can work with images that have up to eight bits per pixel. The number of bits per pixel de-

An example of an image, greatly magnified
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termines how many separate colors the image can contain. Images in GIFConverter can contain up to 256 
colors each (this is because 28=256).

Color Maps and Color Tables

When images have 256 colors or less, they often use a color map or color table. This allows the images to 
use a specific set of 256 colors. A color monitor can really display 16,777,216 colors. That corresponds to 
24 bits per pixel, but a 24-bit-per-pixel image takes three times as much memory as an 8-bit-per-pixel im-
age. Also, working with 24-bit-per-pixel images is much slower.

The color map or table is simply a list of RGB colors. Each entry in the list has a color value for the red, 
green, and blue values that should be sent to your screen (hence RGB). Red, green, and blue are called the 
additive primaries because all colors can be represented as a mixture of red, green, and blue.

The computer then uses the value of each pixel in the image to look up the color in the table. If it finds a 
pixel that has the value 5, it looks at color #5 in the table, and sends that RGB value to the screen. Some-
times a color table used in this way is called a Color Look-Up Table or CLUT.

Color tables are often handy for making quick color adjustments for the image. Instead of changing the 
thousands of pixels in the image, a program like GIFConverter need change only the 256 color entries in 
the color table to get the desired effect.

Dithering and Halftoning

Dithering and halftoning are two ways to adapt an image to a particular set of colors. This set of colors can 
be more than just black and white. Both of them depend on the human eye’s ability to blend details. 

The most common use of halftoning is in the printing of photographs in newspapers and magazines. A pho-
tograph has a range of intensities, but a printing press has only two—either there is ink on the page or there 
is not. Halftoning converts a image into a field of spots. The size of each spot corresponds to the darkness1 
at that point. Light areas have small spots spaced a distance apart. Areas that are almost black have spots 
that grow together and touch. In the darkest areas, the white spaces between the spots disappear entirely.

On computers, we simulate the spots with groups of pixels. See the examples of halftoning methods in the 
section entitled The Display. 

Dithering is another method of reducing the number of colors. In dithering, the computer chooses colors 
so that the average effect you see corresponds to the average color for an area of the image. Dithering does 
not have discernable spots like a halftone, but can sometime have other undesirable patterns.

Macintosh Displays

The original Macintosh screen had only one bit per pixel. It could only show two colors, black and white. 
Color Macintoshes can display two, four, or eight bits per pixel (4, 16 or 256 colors) with a color table. If 
you have the right hardware, your Macintosh may display what it calls thousands or millions of colors. 
These are 15 or 24 bits per pixel, but use RGB values directly instead of a color table.

1 Darkness is the inverse of intensity. We print with black inks on white paper, so darkness is appropriate 
here.
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Inside a GIF File

Now that we’ve defined some terms, we’re ready to look at the organization of a GIF file:

A GIF file can contain one or more images. Each image has a color table that defines up to 256 colors. The 
GIF file has a background color that’s used to fill the spaces between images, if any.

The first GIF standard was called GIF87a. There is a new standard, GIF89a, which defines some exten-
sions to the GIF file format. GIFConverter currently supports only the comment text extension to the GIF 
format.

A GIFConverter document in memory is organized the same way as a GIF file. The images appear in a 
window, and you can call up a separate window for the comment text.

Setting Up GIFConverter

System Requirements
GIFConverter requires the following system configuration:

• A Macintosh 512KE, Plus, SE, SE/30, Classic, Classic II,LC, any Macintosh II, or any Macintosh 
Quadra.

• System 6.0.5 or newer; latest System 6 or System 7 preferred.

Image

Color Table

Background Color

one or more images 
with color tables

Comment Text

GIF File GIF89a only
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• At least 512K of RAM. This will allow you to work with the smallest GIF files. 1Mb of RAM or more 
recommended for best results. GIFConverter requires 1 byte of memory for each pixel in a document. 
For a 320 x 200 pixel document, GIFConverter requires 64000 bytes. Some operations require twice 
that amount. You may need to give GIFConverter 2.5Mb or more to work on large documents. Ex-
tremely large amounts of memory (or virtual memory) may be required to work on large 24-bit TIFF 
or JPEG files.

Installing GIFConverter

GIFConverter requires no special installation. Simply copy the GIFConverter program icon from the orig-
inal diskette to your hard or floppy disk.

License Key
When you received GIFConverter, the package included a sticker with your name, and a key. It looks 
something like this:

When you first start GIFConverter after copying it to your hard disk, you will receive a dialog box that 
stresses shareware registration and allows you to enter the key. Simply type in the key from the last line 
of the label and click on the OK button. The key consists of numbers 0 through 9 and letters A through F. 
The hyphens are optional.

You will have to re-enter your key every time you copy the GIFConverter program to a different location. 
Entering the key will prevent the key dialog box from appearing every time you run GIFConverter. All 
functions in GIFConverter will always work, even if you skip the dialog box by clicking on the OK button.

Configuration File
GIFConverter creates a file called “GIFConverter Prefs”. This file contains the settings from the Options 
dialog box. GIFConverter keeps this file in the Preferences folder inside the System Folder.

Temporary Files
When GIFConverter runs short on memory, it creates files in the Temporary Items folder on the system 
disk to store some of the images it’s working with. GIFConverter will never use more than half the free 
space on your disk, nor the last 100K of space.

#001 - Kevin A. Mitchell
Product: GIFConverter
Version Limit: 2   Exp. Date: none
01-23-45-67-89-AB-CD-EF
4   GIFConverter



                  
These files are named with “GIFConverter” and a long number, such as “GIFConverter1308991488”. 
Sometimes, if the Macintosh crashes while GIFConverter is running, these files may be left in the Tempo-
rary Items folder. You may drag these files to the trash, but make sure you quit from GIFConverter first.

Under System 7, the Temporary Items folder is invisible. When you boot your Macintosh, any temporary 
files left in the Temporary Items folder are moved to a folder in the Trash called “Rescued items from disk 
name.” To discard these files, simply empty the trash in the Finder. 

Working with Documents

Opening Documents

Choose the Open… command from the File menu. GIFConverter will list all the documents that it can 
open. Use the Open box the same as you would in any Macintosh program.

Note: GIFConverter can’t read Encapsulated PostScript (EPSF) files. To 
do so accurately requires a PostScript interpreter. There are some 
commercial products, such as TScript or Freedom of Press, that can 
read PostScript data and produce TIFF files.

Normally, Macintosh programs rely on information stored with the file to find out what kind of file it is. 
GIFConverter will tell you what type of file it is when you click on it.

Sometimes a downloaded file will not have the right type. GIFConverter can identify GIF, RLE, TIFF or 
RIFF files by looking inside the files. Depending on which button you press, GIFConverter may show 
more files in the list (see below).

If you choose Trust file type information (fastest), GIFConverter doesn’t look inside any files. It simply 
uses the file type information saved with the file. This is the button that’s checked when the file list first 
comes up.

With Look inside some files (slower) checked, GIFConverter looks in files that have types like TEXT, 
which may actually be files downloaded through a terminal program.
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When you choose Look inside all files (slowest), GIFConverter looks inside all files.

If you choose the latter two options, more files may appear in the list. You can click on the Fix file types 
for shown files button to let GIFConverter automatically add the right type information to the files. If you 
do this, GIFConverter will automatically list the files in the box. In the Finder, their icons will change, and 
they can be double-clicked to automatically open them.

Creating Documents
Choose the New command from the File menu to create a new document. When you save the document, 
GIFConverter will prompt you for the file’s name and type. 

New documents are handy when you want to make a file using the Clipboard. You can cut a picture from 
another program and paste it into the new window.

Saving Documents
To save your document., choose the Save command from the File menu. GIFConverter will save the doc-
ument as the type shown in the status bar and the name shown in the window title. If you have never saved 
the document before, the Save command will behave as the Save As… command.

To save the document with a new name or type, choose the Save As… command. GIFConverter will give 
you the usual Save box with a suggested name based on the file type and display options. The shadowed 
box is a pop-up menu: Click on it to choose the type you wish to save the file as.

The Save a Copy… command works the same as the Save As… command, except that it does not change 
the window title or GIFConverter’s idea of the file type. 

Closing Documents
To close a document, click on the close box in the upper left corner of the window or choose the Close 
command from the File menu.

If you haven’t saved the document since you last changed it, GIFConverter will ask you if you want to 
save the changes. 

Discarding Changes
Choosing the Revert command from the File menu will cause GIFConverter to reread the document from 
the last file you saved it to. This may reduce the quality of what you see on the screen if you last saved the 
file in a format such as MacPaint, which doesn’t store color.

Note: You may not revert a document saved as EPSF.
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The Display

Display Modes

You can control all the display modes through the Display menu.

Screen Depth

Choosing the One Bit command causes GIFConverter to use the old QuickDraw format for drawing to the 
screen and printing. This format allows up to eight colors. This is the only format allowed if your Macin-
tosh doesn’t have Color QuickDraw.

The One Bit command is also useful for making halftones for black-and-white printing.

The Eight Bit command, available if your Macintosh has Color QuickDraw, causes the display to use up 
to 256 colors or gray levels. The number of colors you can see on the screen depends on the Monitors set-
tings in the Control Panel. For best results, use a color card capable of 256 colors or more, and set the Mon-
itors Control Panel for 256 or more colors. Using less than 256 colors can result in a poor display with 
incorrect colors.

Also use the Eight Bit command when viewing documents in full color (24-bit documents).

Color

Choosing Cyan, Magenta, Yellow, or Black displays one of the components of a four-color separation. 
A four-color separation is used in printing to create full color graphics. It uses four inks. Cyan, Magenta, 
and Yellow are used because they are what we call the subtractive primaries, colors that can be used to 
create any color on paper. The process also uses Black because it is hard to create accurate grays by mixing 
colored inks. 

Choosing Grayscale displays the a gray version of the image, like watching a color television program on 
a black-and-white TV.

Choosing Color displays a color image. In One-Bit mode, GIFConverter creates a special format needed 
for color printing in this mode. On a Color QuickDraw Macintosh, the colors will display as they print on 
an ImageWriter II. On other Macintoshes, the display may be almost black, but GIFConverter will still 
print in color on the ImageWriter II.

Default Display Modes

The default modes are Eight Bit  and Color if you can display more than two colors on your screen, oth-
erwise One Bit and Grayscale.

Dithering Options

Dithering is a method used to represent grayscale or color images on a  black and white screen. GIFCon-
verter dithers when displaying these images in the One Bit display mode. Choosing Automatic Dither in 
the Special  menu will redither the display automatically when necessary after image processing or sizing 
changes. Otherwise, choose the Recalculate command from the Image menu to force redithering of the 
images.

Turning off automatic dithering can save some time when performing multiple changes, such as some im-
age enhancement, display mode changes, and rotating an image. 
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The available dithering options appear on the Dither submenu under Special. These options are:

1. Ordered. This is the traditional ordered dither method. This method works quickly, but results in 
X-shaped patterns.

2. Floyd-Steinburg. This dithering method uses error diffusion. It looks good on the screen or on low-
resolution dot-matrix printers like the ImageWriter.

3. Halftone 0°. This method is actually a halftone; a fine distinction from dithering. The output from 
Halftone 0° is a 60 lines per inch spiral halftone similar to that found in newspapers. This halftone 
simulates dark spots corresponding in size to the darkness of the image at that point. The grid is at 
an angle of 0 degrees, parallel to the edges of the paper. This option works best when combined with 
the Set Resolution command and printed on a 300 dpi laser or ink-jet printer.

4. Halftone 53°. This method produces a halftone similar to the Halftone 0° option, but wit h the grid 
rotated 53 degrees counterclockwise. The rotated grid of dots tends to cause less noticeable jagged-
ness around horizontal and vertical edges in the picture.

See the accompanying figures for examples of the dither methods.

Page Breaks

Choosing the Show Page Breaks option turns on the display of page breaks in the document. Page breaks 
show as striped lines, and are not printed. 

Choose Show Page Breaks again to turn off the page break markers.

Ordered Floyd-Steinburg

Halftone 0° Halftone 53°
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Display determines Save and Print style

GIFConverter always prints the image the way it shows on the screen. It also uses the screen display to 
determine how to save a PICT file. For instance, saving a PICT file with the display set to One Bit creates 
a PICT version 1 file, but settings of Eight Bit will create a PICT 2 file that can contain the color informa-
tion.

For many other file formats, you have a choice of how many colors you want to save. See the individual 
file format descriptions for more information about what information GIFConverter saves with each for-
mat.

Carol
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Window Features

Scrolling display area

The largest section of the window is taken up by the display area, which shows the images in the document. 
This area may be scrolled with the scroll bars or the hand tool.

Status bar

The status bar runs along the top of the window. This area displays the type and size (in pixels) of the cur-
rent image. 

When clicking on an image, the status bar shows the dimensions and number of colors in that image.

When stretching an image, it shows the size of the image and the percentage change. 

Tool bin

The tool bin contains an icon for each of the three tools. Click on the desired tool to select it. You may also 
select tools by using the Tools menu, or the command-key equivalents.

Full-Screen Windows

The Full Screen command makes the frontmost window cover the whole screen. Choosing the Full 
Screen command again will return the window to its original size.

Hiding the Menu Bar

The Hide Menu Bar command will remove the menu bar from the screen, offering more viewing area. 
When the menu bar is gone, print  -B to restore the menu bar.

tool bin

status bar

display area
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The Editing Tools

 Pointer Tool

You can use this tool for selecting, resizing and moving images. See the section on selecting images below 
for more information.

 Marquee Tool

This tool marks an area in the document for use with the Copy or Crop commands. 

 Hand Tool

Use the hand tool to move the document around. Clicking inside the scrollable area with the hand tool 
scrolls the document without using the scroll bars. This is also handy when using the Full Screen mode.

Holding down the option key always causes the hand tool to appear regardless of what tool you have se-
lected.

Selecting Images
Selecting Entire Images

To select an image, first choose the Pointer tool.

To select a single image, click inside the image. Selected images have thick diagonally-striped borders.

To add or remove images from the selection, hold down the Shift key and click on an image.

If you click outside of any image and then drag, you sweep out a rectangle with a dotted border. This rect-
angle selects any images it touches.

Selecting Portions of Images

To select portions of images, choose the Marquee tool. Click and drag the mouse, and a dotted rectangle 
will appear. This rectangle outlines the selected area. The size of the selection appears in the status bar.

After selecting portions of an image, you can use the Copy or Crop commands.

Using the Clipboard
Cut

The Cut command removes the selected images and places them on the clipboard. Areas selected with the 
marquee may not be Cut.

Copy

The Copy command places a copy of the selected images on the clipboard.
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If you select an area with the marquee, then chose Copy, GIFConverter places the areas of images that fall 
within the marquee onto the clipboard.

Paste

The Paste command replaces the currently selected images with the images in the clipboard. If you haven’t 
selected any images, GIFConverter places the images in the clipboard into the document with their top left 
at the last point where you last clicked the mouse.

Moving Images
To move images, first select the images you want to move as described above. Then, using the pointer tool, 
click inside one of the images, and drag the images to the new location. A dotted outline of the images will 
follow the cursor showing their new location. When you release the mouse button, the images will redis-
play at their new location.

Stretching Images
To stretch images, click in the striped border of one if the images.

If you click near the center of an edge of the image, you will move that one edge in all the images.

If you click near the corner of an image, you move the corresponding corner of all images.

Holding down the shift key constrains the stretching to keep the proportions of the original images.

While stretching, the status bar shows the new size of the images in pixels and as a percentage.

cl ick and drag in corner
to resize in both direct ions

cl ick and drag in edge
to resize in one direct ion
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Scaling Images
Scaling an image changes its size. This is like stretching, but you can enter the scaling percentage directly.

First select the images to scale by clicking on them with the pointer tool.

Then select the Scale command from the Image menu. You will see a dialog box that looks like this:

Type in the scaling factors as a percentage from 25% to 6400% in either direction, then click on the OK 
button. It is not necessary to scale by the same amount in each direction.

Rotating Images
To rotate images, first select the images to rotate as described above.

Then, select the Rotate command from the Image menu. A submenu will appear; choose the rotation, 
which will be a multiple of 90°. 

The selected images will rotate around their common center. After rotation in one-bit mode, GIFConverter 
will redither the images regardless of the automatic setting.

Cropping Images
To crop an image, use the marquee to enclose an area of the image, then choose the Crop command from 
the Image menu. Any image or portion of an image not enclosed by the marquee selection is removed.

GIFConverter automatically crops images  when they are moved to the Clipboard if the Copy command 
is chosen after a marquee selection.

Only images with 256 colors or less can be cropped by this version of GIFConverter. To rotate images with 
more than 256 colors, use the Change Color Palette… or Reduce Number of Colors… commands.
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Changing the Resolution
You can also change the resolution of the document to match that of high-resolution printers. This results 
in smoother-looking output. Changing the resolution affects the whole document, including all the images 
contained in it. 

You can optionally rescale the images to account for the new resolution. This makes the images keep their 
size after the resolution change. Otherwise, increasing the resolution would cause the images to print 
smaller.

Documents with increased resolution still display on the screen at 72 dots per inch (dpi). GIFConverter 
places the resolution information into PICT files and the clipboard, so you can paste high-resolution half-
tone images into other programs. Also, GIFConverter will print directly at the higher resolution.

Increased resolution works better with the Halftone dithering methods and 300 dpi (or greater) laser or ink-
jet printers. It is not necessary to have a PostScript printer to take advantage of halftones with this method. 
If you do have a PostScript printer, it is better to leave the document at 72 dots per inch since the printer 
does its own halftoning.

To change the resolution of the document, choose the Set Resolution command from the Image menu. 

You will see a dialog box that looks like this:

Choose the resolution you wish to use. Note that you use 288 dpi with 300 dpi printers; when printing on 
these printers, choosing the “Precision Bitmaps” option alters the scaling to account for this difference. 
Without “Precision Bitmaps,” the images will print with horizontal bands running through them.

Make sure to check the “Also rescale images to new resolution” box if you want the images to stay the 
same size when printed. Otherwise, increasing the resolution causes the images to become proportionally 
smaller.
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Changing the Color Palette
GIFConverter can change the color palette for an image or group of images. You may find changing the 
palette useful for making Startup Screens that display with the right colors, or custom icons for System 7, 
or for making GIF files with less colors that take up less space on the disk.

First, select the image or images you wish to change the palette for. Then, choose the Change Color Pal-
ette… command from the Image menu. You will see a dialog box that looks like this:

The shadowed rectangle is a pop-up menu. Click on it and choose a color palette. When you click on OK, 
GIFConverter will change the selected image or images to use the colors you chose. This may take a few 
minutes, and a progress box will appear to show how far the conversion has gone.

These are the color palettes available to you:

When making a Startup Screen, use the Standard Colors or Grays that correspond to the Monitors control 
panel setting.

Palette Contains

Apple Icon Colors The 39 colors that Apple recommends for color icons in System 7.

Black and White Just Black and White.

Imagewriter II Colors The eight colors available from an ImageWriter II with a color ribbon.

RGB 8 Colors The eight colors in the corners of the RGB color cube: Black, White, Red, 
Green, Blue, Cyan, Magenta, and Yellow. This is the smallest set of colors that 
will work with every picture without strange color effects.

Standard 16 Colors The colors on the screen when you set the Monitors control panel to 16 colors.

Standard 16 Grays The colors on the screen when you set the Monitors control panel to 16 grays.

Standard 256 Colors The colors on the screen when you set the Monitors control panel to 256 col-
ors.

Standard 256 Grays The colors on the screen when you set the Monitors control panel to 256 grays.

Standard 4 Grays The colors on the screen when you set the Monitors control panel to 4 grays.
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Reducing the Number of Colors
You can also reduce the number of colors in an image or set of images. When you reduce the number of 
colors, GIFConverter calculates which set of colors would work best with the images you’ve selected, and 
uses those colors to redither the images like the Change Color Palette… command.

First, select the image or images you wish to change the palette for. Then, choose the Reduce Number of 

Colors… command from the Image menu. You will see a dialog box that looks like this:

Type in the number of colors you wish to use, and choose between colors or grays. You can’t reduce an 
image to less than 8 colors or 2 grays. When you click on OK, GIFConverter will change the selected im-
age or images to use the colors it has chosen for the images. This may take a few minutes, and a progress 
box will appear to show how far the conversion has gone.

Working with Comments
GIFConverter can store comments in GIF version 89a files. If you open a file that contains comments, they 
will appear in a window entitled “Comments for filename.” You can see the comments window for a doc-
ument or create new comments by choosing the Show Comments command from the Windows menu.

You can edit the comments using the Cut, Copy and Paste commands. You can also print them to any 
connected printer.

Undoing the Last Operation
Many operations are undoable. If the last command you chose is not undoable, GIFConverter will make 
the Undo command gray on the Edit menu. 

Memory Usage
Choosing the Show Memory command from the Windows menu will produce a small window showing 
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the amount of memory used. 

RAM

The dark part of the RAM bar graph shows the proportion of available RAM GIFConverter is using to store 

the documents you’re working on. The number to the right of the bar is the total amount of memory avail-
able in K (kilobytes). This figure does not include memory GIFConverter uses permanently, so it will al-
ways be less than the Multifinder memory setting.

Disk Image Buffers

When GIFConverter doesn’t have enough memory to proceed, it will try to find enough memory to use by 
placing some of the images to the temporary file on the disk. Generally, GIFConverter needs to keep only 
images it is currently working on in memory. Effectively, the number of documents you can open is lim-
ited only by the amount of disk space you have available. 

GIFConverter indicates when it is placing data on the disk by changing the cursor to a special “swapping” 
cursor. This cursor indicates the flow of data into or out of the disk.

The dark part of the Disk bar graph shows the proportion of the available disk space GIFConverter is using. 
The number to the right of the bar is the total amount of disk space that GIFConverter will use in K (kilo-
bytes). Remember, GIFConverter doesn’t use more than half of the available disk space, nor the last 100K.

Enhancing Images

Image Processing Fundamentals
Image processing is a group of methods, all of which change the way an image looks. These techniques 
are useful in many ways. You can correct images that are too dark or too light, that lack contrast, or are 
washed out. You can also create special effects with image enhancement.

GIFConverter supports some image enhancements that fall into the category of point processes. These are 
effects that take place individually for each pixel (point) in the image. Changing the brightness is an ex-
ample of a point process.

Stretching and rotation, mentioned earlier in this manual, are examples of a geometric process. A geomet-

“Swapping” Cursors
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ric process changes the position or arrangement of pixels in the image.

There are two kinds of processing that GIFConverter does not do: area and frame processing. An area pro-
cess changes a pixel’s value based on its own value and the value of neighboring pixels. One example of 
an area process is sharpening, which enhances edges. A frame process calculates a new image that is a 
combination of two previous images.

Gray Map

A gray map is a function that assigns a new intensity to a pixel based on that pixel’s current intensity. A 
pixel of the lowest intensity is black, and a pixel of the highest intensity is white. A pixel of intermediate 
intensity may be gray or have a color. As a bright color is moved toward white or black, it loses saturation, 

or colorfulness.

The example above is a gray map that makes no changes to the image. For each intensity level on the input, 
the curve defines an output intensity level (dashed line). 

Histogram

A histogram is a graph that shows how much of the image has a certain intensity.

The height of the histogram at any particular point shows the number of pixels or area of the image that 
has that intensity. The output side has no units. This is because the relative values are more important than 
any absolute value. In this case, the image is made up of mostly dark values.

Histogram Equalization

Histogram equalization is a technique that generates a gray map which changes the histogram of an image 
to be as close as possible to a user-specified desired histogram. This technique is useful for processing im-
ages that have little contrast. Typically, the desired histogram is a level one, meaning that all intensities 
are equally represented in the image. The net effect is to turn an image with details imperceptible to the 
eye into an image that is easily seen.

Input

Output

An example of a gray map.
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Gamma

Gamma is a measure of the nonlinearity of a monitor. This means that the RGB values we send to the mon-
itor do not correspond to the intensity we see in a linear fashion. The intensity seen on a monitor can be 
specified as:

I=Vγ

I is the intensity seen on the screen, V is the value from the image, and γ is the gamma.

The Macintosh is set up so that the gamma is 1, so the intensity is directly proportional to the values we 
send to the screen.

Here are gray maps representing a gamma less than one, and a gamma greater than one:

Input

Output

An Example Histogram.

Output

Input

Output

Input
Gamma < 1 Gamma > 1
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Some images may appear washed out. This is because the values in the image have been corrected for sys-
tems that have a gamma greater than 1.

Image Processing in GIFConverter
GIFConverter’s internal image processing apparatus looks like this:

GIFConverter takes the following steps in applying image enhancement:

1. The image is inverted and gamma-corrected if specified.

2. The histogram for the image is compared to the desired histogram, resulting in the histogram equal-
ization gray map. If histogram equalization is turned off, this gray map becomes the identity gray 
map, and makes no changes to the image.

3. GIFConverter generates a gray map for the contrast and brightness based on the contrast and bright-
ness controls.

4. The histogram gray map, user-specified gray map, and contrast-and-brightness gray map are com-
bined into a single gray map to be applied to the image.

5. The combined gray map is applied to the image to produce the finished result.

The Image Enhancement Dialog
You are able to invoke all the image enhancement features through the Enhance… command on the Im-

+ +

invert and 
gamma 
correct

input image output imagecombined
gray map

histogram

user-specified
gray map

contrast and
brightness
gray map

contrast
and 
brite

controls

histogram
equalization

gray map

①

➁ ➂

➃

➄
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age menu, which produces the following dialog box.

Note: GIFConverter can’t enhance images with more than 256 colors. If 
you need to make enhancements on images with more than 256 col-
ors, use the Reduce Number of Colors… command first.

To enhance images, first select the images with the pointer tool. Image enhancement does not work on por-
tions of images. You can only enhance entire images.

The Enhance dialog box consists of two main areas:

• The Display shows data at a specific point in the image enhancement process described in the previous 
section. When viewing the Desired Histogram or User-Specified Gray Map modes, clicking and 
dragging in the display changes the histogram or gray map.

• To the right of the display are several controls that change the way GIFConverter displays an image.

When you click on the OK button in the Enhance dialog box, GIFConverter applies the settings to all the 
images that you selected.

The Display

The large area at the left of the dialog box is the display area. Above the display is the Display menu. This 
menu selects the data that shows in the display area. 

Click on the display menu to choose among the options:

• Original Histogram. This display contains the histogram of the original image data.

• Desired Histogram. This display shows the desired histogram. You can change the histogram as de-
scribed below.

• Histogram EQ Gray Map. This display shows the gray map resulting from the application of Histo-
gram Equalization.

• User-Specified Gray Map. This display shows a gray map that you may modify to manually alter the 
intensity of the image.

• Contrast & Brightness Gray Map. This display shows the gray map that results from setting the 
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Contrast and Brightness controls.

• Combined Gray Map. This display shows the gray map resulting from combining the histogram 
equalization gray map, the user-specified gray map, and the contrast and brightness gray map.

• Final Histogram. This display shows the effects of applying the combined gray map to the images 
being enhanced.

Gamma Correction

The Gamma slider allows you to change the input characteristics of GIFConverter’s image display sys-
tem. When viewing a washed out image, adjust the gamma to a value in the range of 1.5 to 2.2.

Inverting the Image

Sometimes, when GIFConverter reads an image, it comes out negative. Some TIFF files do not contain an 
explicit specification of how to represent black and white values. GIFConverter makes an assumption 
about this representation according to the TIFF specifications, but images from some programs still appear 
inverted.

Check the Invert Image button in the dialog box to cause GIFConverter to reverse the image values. This 
will create a negative of the image, which will correct for images that start as negatives.

Histogram Equalization

Histogram Equalization is a technique for increasing the detail of an image that is lacking in contrast. This 
technique changes the intensity levels in the image to cause the image to conform to some desired histo-
gram. Histogram Equalization helps the quality of dithered images in the One Bit mode. Sometimes, this 
technique increases the contrast too much.

To turn this feature on, check the Histogram Equalization check box.

The default histogram contains equal amounts at all intensities. To change the histogram, select Desired 
Histogram from the Display menu in the dialog box. Then draw the desired histogram into the display 
box with the mouse. Press the Reset button to return to the default histogram.

Contrast and Brightness Control

The Contrast and Brightness controls operate similarly to the controls on a TV set. 

The Contrast control is measured as a percentage. 100% corresponds to normal contrast; lower values in-
dicate less contrast and higher values indicate more contrast. The contrast can be adjusted from 25% to 
400%.

The Brightness setting is an intensity value that is added to all values in the image.

User-Specified Gray Map

The user-specified gray map offers the opportunity to apply unusual changes to the image. 

To alter this gray map, select User-Specified Gray Map from the Display menu in the dialog box. Draw 
the desired gray map into the display area. Click on the Reset button to restore the default gray map.
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Image Enhancement Methods

Deferred Updates
When you turn off Automatic Dithering, you will not see your changes immediately. After performing 
an image enhancement, choose the Recalculate command from the Image menu to update the screen.

Printing Documents

To print a document, choose the Print… command from the File menu. 

The Page Setup… command allows access to orientation and page size parameters. 

For faster printing, use the Print One command from the File menu. This command uses the last settings 
chosen in the Print… command, or the default settings if no document has yet been printed.

What you see is what you print
When printing with GIFConverter, remember that GIFConverter always uses the current Display settings 
to determine which information to send to the printer. 

Print Margins
GIFConverter allows you to set the print margins it uses for printing. The default print margins are 1 inch 
at each edge of the document. To change the print margins, choose Print Margins… from the File menu. 

If… Then try…

You got the images from another computer 
(not a Macintosh), and they are washed out.

Increasing the Gamma to a value of 1.5 to 2.2.

The image is a negative. Areas that should be 
dark are light, or vice versa.

Clicking on the Invert Image button.

The image appears to be all one intensity. De-
tails can hardly be seen

Turning on Histogram Equalization.

The image is too bright or too dark. Adjusting the Brightness control.

The image needs more or less contrast. Adjusting the Contrast control.

You want to experiment with special effects. Changing the User-Specified Gray Map.
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You will see a dialog box that looks like this:

You can type the margins for each edge of the page into the corresponding area in the dialog box. Click 
on a Units button to change the units in use. You can also specify units by following your measurements 
by pt (for points), cm (for centimeters), or in (for inches).

When you click OK, GIFConverter uses the print margins you’ve set for the document. 

ImageWriter
Images print best on the ImageWriter if you select One Bit mode.

Eight-Color printing

To print color images on the ImageWriter II, follow these steps in this exact order:

1. Turn the printer off.

2. Install a color ribbon according to the instructions in the owner’s manual.

3. Now, turn the printer on. Installing the ribbon with the printer on may cause the ImageWriter to mis-
identify the ribbon type.

4. Choose the One Bit and Color options in the Display menu.

5. Choose the Page Setup… and Print… commands to print the document.

6. Some large documents run into a memory limitation in the ImageWriter printer driver. When this 
happens, your printer will give you blank pages. To correct for this, you may have to choose the 2 x 
11” Pages option in the Page Setup… dialog box. If you do so, also choose No Gaps Between Pag-
es. 

GIFConverter applies a color correction to the color data to compensate for the inks used in a typical four-
color ribbon. The color printing process is inexact, and results may vary according to the type of paper 
used, and the manufacturer and age of the ribbon.
24   GIFConverter



LaserWriters and other PostScript Printers
If the chosen printer driver is LaserWriter, GIFConverter generates PostScript halftones to represent the 
screen data. It is not necessary to use halftone patterns or increased resolution to print on these printers.

If you choose the Grayscale or Color options, GIFConverter sends PostScript data to create a Grayscale 
image. GIFConverter does not currently support the colorimage PostScript operator.

If you choose one of the color separations, Cyan, Magenta, Yellow, or Black, GIFConverter generates a 
halftone image representing the color component. 

LaserWriter 6.0 Supports Color Printers

When printing with LaserWriter 6.0 (or newer) and Color QuickDraw, GIFConverter does not generate 
the halftones itself. Instead, it sends the displayed picture directly to the printer, and prints it using the de-
fault screen angles configured into the printer. When using LaserWriter 6.0, make sure to turn on the Col-
or/Grayscale printing option, otherwise the images will print incorrectly.

LaserWriter 6.0 supports PostScript printers that directly generate full-color images.

High-Resolution QuickDraw Printers
GIFConverter can also print on High-Resolution QuickDraw printers. These are laser or ink-jet printers 
that use the Macintosh to do the actual drawing, rather than accepting PostScript data. When printing on 
these printers, choose the Precision Bitmaps option in the Page Setup dialog box if supplied; otherwise, 
printing bitmapped images from GIFConverter will result in striped patterns in the images. Some printers, 
like the StyleWriter, do not need Precision Bitmaps.

Printing halftone images

Here’s what you have to do to print halftone images, assuming you have a QuickDraw printer that has at 
least 300 dpi output (lower resolution doesn’t work as well):

1. Set the Display menu to One Bit and Grayscale

2. Choose one of the halftone dithering methods from the Dither submenu on the Special menu. 

3. Choose the Set Resolution command from the Image menu. Pick an appropriate resolution, with 
image rescaling turned on.

4. If GIFConverter does not automatically redither the image because you have Automatic Redither 
turned off, choose the Recalculate command from the Image menu. The display on the screen 

Printer Resolution

ImageWriter 72 dpi

ImageWriter II 144 dpi

LaserWriter, DeskWriter, and most other laser and inkjet printers 288 dpi

StyleWriter 360 dpi
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should contain blobs of various sizes. This is the halftone image.

5. Choose Page Setup. Make sure the Precision Bitmaps option is on, if there is one for the printer 
you’re using.

6. Choose Print and print in the normal fashion.

Third-Party Printers
GIFConverter is compatible with third-party printers that use special drivers. When printing to these print-
ers, GIFConverter sends the contents of the screen onto the printer according to the current Display set-
tings. 

Color printing on third-party printers requires Color QuickDraw.

Setting Options

Choose the Options… command from the Special menu. The following dialog box will appear:

Remove Unused Colors
If this box is checked, GIFConverter will automatically scan images for unused color entries in their color 
maps when it opens them. GIFConverter then removes unused colors. The calculations required for remov-
ing unused colors takes quite some time. Uncheck this box to gain some speed when loading GIF files.

Allow Backgrounding (MultiFinder)
If you check this box, GIFConverter allows other programs to run in the background when the “Juggler” 
cursor is visible. Unchecking this box may speed up some operations like dithering or reading a file when 
using MultiFinder.
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File Settings
If you choose the File Settings… command from the Special menu, the following dialog box will appear:

This is a general purpose dialog box. Click on the file type popup menu at the top, and choose which file 
you want to change the settings for.

Using this box, you can choose the number of colors you want to save in the file. Underneath that, there is 
a box that allows you to choose whether to compress the file, and a button that lets you adjust the com-
pression settings.

There are also four general buttons. See the descriptions of the file formats for descriptions of the options 
you can set for each file.

You can also adjust the file settings by clicking on the Options… button when saving a file.

use these controls to turn on compression and adjust compression settings

use this menu to select how many colors to save
choose a file type to work with

these controls depend on which file type is selected

When saving a file
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Working with Slide Shows

Creating a Slide Show
To create a Slide Show Document, choose the New Slide Show command from the File menu.

Adding Files

To add files, choose the Add… command from the Show menu. You will get a window that allows you 
to open multiple files.

The list at the bottom holds the files you’ve selected. To add a file, click on it, then click on Add. To add 
all the files in the folder, click on Add All. When you are finished, click on Done. 

The document window will then look like this:
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Selecting

To select files in the document, click on them. Holding down the Shift key and clicking will choose all the 
files between the one originally clicked and the one newly clicked. Holding down the Command key will 
allow individual files to be selected or unselected.

Deleting Files

To delete files, select them and use the Clear command on the Edit menu, or press the Backspace key.

Moving Files

To change the order of files in the slide show, select a group of files, then use one of the Move… com-
mands on the Show menu, or the arrow keys on the keyboard, to move them up or down.

Saving and Opening Slide Shows

You can use the commands on the File menu to open and save slide shows.

Opening files through a Slide Show

To open files through the Slide Show window, choose the files you want to open, then choose the Open 
Selected… command from the Show menu.

Playing a Slide Show
To run the slide show, choose the Play command from the Show menu. To make the show run in a con-
tinuous loop, choose the Loop command from the show menu.

Stopping the Show

To stop the Slide Show if it is in a loop, or before it finishes, hold down the Command key and press the 
period key (.).

Skipping to the Next Slide

To skip to the next slide before the time runs out, press a key on the keyboard, or click the mouse.

Changing the Time Between Slides

Choose the Show Options… command from the Show menu, and type in the number of seconds within 
slides, then click on OK.
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Working with Other Applications

Using Multifinder or System 7
Choosing Memory Size

GIFConverter comes preconfigured to run with 768K of memory under Multifinder. This memory is 
enough to work on 320x200 pixel images. Even though GIFConverter stores data on the disk when neces-
sary, it must have enough memory to store the images it’s actively working on. This might be one image 
it’s drawing on the screen, or two or more images when performing more complex operations.

When working with larger images, try using 768K or 1024K. To do this, quit GIFConverter, then find the 
GIFConverter icon in the Finder. Click on it, and select Get Info from the File menu. Type the new size 
into the box marked Current Size (in System 7) or Application Memory Size (in System 6). Then close the 
Info window.

GIFConverter will almost certainly fail if you reduce the memory size to less than 320K.

Running GIFConverter in background

When the “Juggler” cursor appears, GIFConverter is performing an operation that may take a long time to 
complete. GIFConverter can run in the background if you’re using Multifinder. You can click on other 
windows and work with other applications or use the Finder.

When the possibly lengthy operation is complete, GIFConverter will beep and a small version of the GIF-
Converter icon will flash over the application menu (System 7) or the Apple Menu (System 6). Then you 
can use either menu to go back to GIFConverter to continue working.

Using the Clipboard
GIFConverter places images on the Clipboard according to the Display settings in effect when the Cut or 
Copy commands were selected. If Color QuickDraw is present and you select the Eight Bit mode is, the 
clipboard will contain a PICT2 image.

Some applications will work better with One Bit or Grayscale settings.

To paste high-resolution halftone images into other applications, such as word processors or page layout 
programs, follow these steps:

1. Set the Display menu to One Bit and Grayscale

2. Choose one of the halftone dithering methods from the Dither submenu on the Special menu. 

3. Choose the Set Resolution command from the Image menu. Pick an appropriate resolution, with 

“Juggler” Cursor
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image rescaling turned on.

4. If GIFConverter does not automatically redither the image because you have Automatic Recalcu-
lation turned off, choose the Recalculate command from the Image menu. The display on the 
screen should contain blobs of various sizes. This is the halftone image.

5. Click on the images you wish to copy with the pointer tool.

6. Use the Copy command to copy the images to the clipboard.

7. Switch over to the other application and paste the images. Before printing from that application, 
choose Page Setup. Make sure the Precision Bitmaps option is on, if there is one for the printer 
you’re using.

Placing Postscript halftone images into Microsoft Word
Using GIFConverter, you can easily put scanned graphics into Microsoft Word documents:

1. Open a document with GIFConverter.

2. Select the area you wish to use as a graphic and invoke the Crop command. Use the pointer tool to 
push the image into the upper left hand corner of the document. You may also resize or rotate the 
image, but the point is to get the size you want and have it in the upper left hand corner.

3. Use the Save a Copy… command to save the document as an EPSF text-only document.

4. Copy the image to the clipboard.

5. Open the Microsoft Word document.

6. Paste the image into the document.

7. Use Microsoft Word to open the EPSF file.

8. Select the entire contents of the EPSF file, from the beginning of the line that says “%!PS-Adobe-
2.0 EPSF-1.2” to the end of line that says “%%EndEPSF.”

9. Copy the selected part of the EPSF file.

10. Paste the EPSF contents into your document before the image that was just pasted.

11. Type in the word “.pic.” before the line that starts “%!PS-Adobe-2.0.” Press return to make it a sep-
arate paragraph.

12. Select the entire EPSF graphic, from the line reading “.pic.” to the line reading “%%EndEPSF” and 
assign it the Postscript style by using the Styles command from the Format menu. This style is also 

Printer Resolution

ImageWriter 72 dpi

ImageWriter II 144 dpi

LaserWriter, DeskWriter, and most other laser and inkjet printers 288 dpi

StyleWriter 360 dpi
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“hidden text,” so the lines may disappear depending on the Show Hidden Text setting.

If you turn on the Show Hidden Text, and the Show ¶ commands in Microsoft Word, your window 
should look like this:

13. Choose the Page Setup… command from the File menu, and check the Print Postscript over Text 
option.

When printing on a PostScript printer, you will see the halftoned image. On other printers, you will see the 
picture you pasted in.

Some versions of Microsoft Word have a bug that cause PostScript graphics to be misaligned on the first 
page of the Word file. If this causes a problem, add a blank page at the front of your job with the Insert 
Page Blank command.

Note: If you’re using Microsoft Word 5.0, you can simply insert the 
graphics file using the Insert Picture menu command.

Using halftone images with QuickDraw printers 
If you have a high-resolution QuickDraw printer, you can use the following method to place halftone im-
age into documents using a word processor or other application that accepts graphics from the clipboard:

…PostScript code deleted for clarity…

the .pic. paragraph you typed in

the graphic you pasted in

the data from the EPSF file
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1. Open a file with GIFConverter.

2. Select the area you wish to use as a graphic and invoke the Crop command. Use the pointer tool to 
push the image into the upper left hand corner of the document. You may also resize or rotate the 
image, but the point is to get the size you want and have it in the upper left hand corner.

3. Make sure to set the Display menu to One Bit and Grayscale

4. Choose one of the halftone dithering methods from the Dither submenu on the Special menu.

5. Choose the Set Resolution command from the Image menu. Set it to a resolution of 288 dpi, with 
image rescaling turned on.

6. If GIFConverter does not automatically redither the image because Automatic Recalculation is off, 
choose the Recalculate command from the Image menu. The display on the screen should contain 
blobs of various sizes. This is the halftone image.

7. Choose Select All from the Edit menu.

8. Choose Copy from the Edit menu.

9. Switch to the other application.

10. Select the location to place the image, then choose Paste from the Edit menu.

Using a communication program to transfer files

Macintosh communication programs generally use a format called MacBinary to transfer binary (non-text) 
files. This format is not compatible with non-Macintosh computers. Because the GIF and TIFF file formats 
are not Macintosh-specific, you will want to send them around without using MacBinary.

This section tells you how to set your communication program for transferring programs without MacBi-
nary. See the communication program’s user manual for complete information on transferring files.

America Online
America Online handles GIF files correctly most of the time. As of this writing, if you download a GIF 
file from an area outside the Macintosh forums, it may not have the right type information. To fix these 
downloads, use the features described in Opening Documents, above.

CompuServe Navigator and Information Manager
CompuServe’s Navigator and Information Manager always transfer GIF files properly. There is no need 
to take any special action.

These programs will upload TIFF files as MacBinary. They may download non-MacBinary TIFF files 
without the proper file type. To fix these downloads so you can open the files, use the features described 
in Opening Documents, above.
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MacTerminal 2.0
Choose the File Transfer… command from the Settings menu. Click on the Straight XModem button.

Microphone II
Choose Protocol Transfer… from the Settings menu. Click on the Binary button. For downloads, you 
can enter the type and creator (the program that the files belong to, and the Macintosh will use to open 
them). Enter GIFf or TIFF for the type (upper and lower case is significant). If you enter GCon for the 
creator, the files will open GIFConverter when you double-click them.

White Knight
Choose File Transfer… from the Options submenu of the Customize menu. Use the options that tell it 
to not use MacBinary for any downloads, and to take no action with non-MacBinary TEXT files.

XModem Transfer Tool (Communications Toolbox)
The Communications Toolbox is a set of connection, terminal emulation, and file transfer tools. One of 
the programs that uses the Communications Toolbox is MacTerminal 3.0.

To download GIF or TIFF files, choose the File Transfer… command from the Settings menu. Make sure 
to choose XModem tool. Click on the Method pop-up menu, and choose Straight XModem.

Other programs
If you don’t use one of the communication programs listed above, the best way to determine how to trans-
fer files is to check your manual. When transferring GIF or TIFF files, make sure you make the following 
settings:

• Turn off MacBinary if uploading. Most programs recognize that GIF and TIFF files are not MacBi-
nary when downloading, so you won’t have to do anything if you’re only downloading.

• Turn off all features that alter downloaded or uploaded TEXT files. These features may mention ad-
dition or removal of linefeeds or control characters. They may also be called filters.

Online Help
If you have trouble accessing files, leave a message to the system operator, or sysop, telling what you are 
trying to do and what problems you are having. The documentation that comes with your subscription to 
a service like CompuServe, GEnie, or America Online will tell you how to do this.
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Supported File Formats

EPSF

Description

EPSF is a special structuring convention for Adobe PostScript files. This convention allows you to embed 
EPSF graphics into other PostScript documents.

Some Macintosh programs can accept EPSF documents and render them onto a PostScript printer.

Input

GIFConverter does not support EPSF. Reading EPSF files requires a PostScript interpreter, which is usu-
ally found in printers, or, rarely, on a computer. GIFConverter does not contain a PostScript interpreter.

Output

GIFConverter creates EPSF documents in two modes. The normal mode has a file type of EPSF, and con-
tains a picture that other programs use when showing the EPSF graphic on the screen. 

If you choose text only, the file has a type of TEXT and contains only the PostScript code. This form is 
ideal for hand editing files or sending the EPSF file to some other type of computer.

GIFConverter places images into the EPSF file as separate objects according to the following table.

Options

Turning on Save as Text causes the EPSF output to be saved to a text file for easier editing.

Restrictions

GIFConverter does not support the colorimage operator. EPSF documents created in Color mode contain 
a grayscale image only.

Display Mode Output

Cyan, Magenta, Yellow, or Black Halftone image containing separation at ap-
propriate screen angle.

Grayscale, Color Halftone image of the gray components.
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GIF

Description

GIF is the Graphics Interchange Format, designed by CompuServe to meet its needs for a machine-inde-
pendent file format.

GIF files can contain one or more images, each containing 256 colors of a possible 16,777,216 colors, as 
well as a colored background. Each image is compressed using LZW2 compression, which can reduce the 
size of the stored image by 30-50% or more. 

GIFConverter fully supports the GIF87a standard.

Input

GIFConverter reads the background color. It reads each  image in the GIF file into a separate image in 
memory. You can edit or move each image in a GIF file individually.

Output

If the Global maps in multi-image GIF files option is turned on, GIFConverter writes GIF files with a 
global color map that encompasses the best compromise colors to use for all the images and the back-
ground color. The global color map helps programs to determine which colors are the best to display before 
reading the rest of the GIF file. Each image has a local color map indicating the precise colors used in that 
image.

Options

Turning on the Save Interlaced option causes GIFConverter to store GIF files  in “interlaced” format, 
which allows online viewers to see some of the image progressively as it arrives over the modem. When 
you check this option, GIFConverter saves every eighth scan line, then every fourth between them, then 
the remaining lines are filled in. This option is for uploading files intended to be viewed online.

Turning on Global maps causes GIFConverter to write a “global color map” when there is more than one 

2 Lempel-Ziv-Welch

Display Mode Output

Cyan, Magenta, Yellow, or Black GIFConverter writes separate images containing the separation 
in its proper color.

Grayscale GIFConverter writes separate images containing grayscale infor-
mation.

Color GIFConverter writes separate images containing full color infor-
mation.
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image. This global map contains summary information about the colors in all the images. Each image still 
contains a list of colors that it uses. This box is initially unchecked since some GIF decoders mishandle 
files that contain both global and local color maps. If you have GIF files with more than one image, and 
other programs display them improperly, try changing this setting.

If the 87a Compatibility checkbox is turned on (which it is when you first start GIFConverter), GIFCon-
verter will warn you if you save GIF files that contain any extensions that require the 89a specification, 
like the text comments. If you want to use comment text, turn off the 87a Compatibility checkbox.

Restrictions

GIFConverter writes eight bit GIF images even when in One Bit mode. This allows you to save GIF files 
with grayscale or color images on black-and-white Macintoshes.

JPEG/JFIF

Description

The Joint Photographic Experts Group developed the JPEG compression scheme to support the digitizing 
and compression of photographs. The compression scheme is “lossy,” that is, it sacrifices some informa-
tion to achieve up to 20:1 compression. The theory behind JPEG is that there is no need to store informa-
tion that the eye can’t see anyway. The color of small details and some of the small details themselves are 
removed before compression.

Even as a lossy compression algorithm, JPEG’s capability to store full-color (24-bit) images in small files 
makes it attractive for electronically handling photographs. A JPEG-compressed photograph exhibits none 
of the graininess seen in photographs compressed with a 256-color scheme such as GIF.

The JFIF format is one of many formats intended for storing JPEG files. JPEG-compressed graphics may 
also be encapsulated in PICT files.

Input/Output

GIFConverter can read and write JFIF files with 256 greys or millions of colors.

Options

If you check the Use QuickTime box, GIFConverter uses an available QuickTime compressor. This box 
is only available if QuickTime is present.

Restrictions

Decompressing and recompressing JPEG graphics many times can cause noticeable changes in the imag-
es.
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MacPaint

Description

MacPaint is a one-bit raster format initially designed by Apple Computer, Inc. It contains a single image 
of 576 x 720 pixels.

Input

GIFConverter reads MacPaint documents into a document containing a single image. If you set the Auto 
Crop on Open option (see the Options… command above), GIFConverter automatically crops the image 
to the smallest portion that contains black pixels. This saves memory, and eliminates unnecessary white 
space automatically.

Output

On output, the upper left 576 x 720 pixels of the document are written into a MacPaint file. 

Options

Turning on the Auto Crop on Open option will cause GIFConverter to crop all paint files to the smallest 
non-white area they contain when opened. This can help when manipulating paint files under memory con-
straints.

Restrictions

In both Eight Bit and One Bit Color modes, the output files will contain blobs of black, since anything not 
white writes as black.  

If the document is larger than 576 x 720 pixels, only the upper left portion will be written to the Paint file.

PICT

Description

The Macintosh uses this format in PICT files, on the clipboard, and in the StartupScreen files (see below). 

Display Mode One Bit Output Eight Bit Output

Cyan, Magenta, Yellow, or Black Dithered bitmap containing a single 
separation.

Not recommended.

Grayscale Dithered grayscale bitmap. Not recommended.

Color Not recommended. Not recommended.
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Most Macintosh graphic programs can read and write PICT files. The conventions listed here for PICT 
input and output apply to all three uses.

The PICT 2 format is an extension of PICT for Color QuickDraw. It can handle a virtually unlimited num-
ber of colors. This version of PICT works best on Macintosh II series and SE/30 CPUs. Other Macintosh 
CPUs can interpret PICT 2 files, but with a loss of all color information: all colors that are not white appear 
as black.

The original PICT format supports eight colors: red, green, blue, cyan, magenta, yellow, black, and white. 
Although all colors except white appear black on the screen, the ImageWriter II printer driver interprets 
these colors properly for printing. 

Input

When reading an original PICT, or on a CPU that does not have Color QuickDraw, GIFConverter reads 
the eight colors available in the original PICT format.

When reading a PICT 2 document on a CPU that does have Color QuickDraw, GIFConverter first scans 
the picture looking for all the colors that it contains. If there are more than 256 colors, GIFConverter 
chooses 256 compromise colors for the document.3 The colors are used to make the color map. GIFCon-
verter then re-reads the picture, mapping each color in the picture to the closest color it has chosen for the 
document.

Output

On output, GIFConverter simply draws the contents of the screen into the PICT file.

If the Eight Bit option is chosen, GIFConverter writes a color PICT 2 picture. It also adds some color table 
information required by early Macintosh II programs.4

Options

PICT files can be compressed if QuickTime is installed. Click on the Set Compression… button to adjust 

3 For technical readers, GIFConverter uses the Median Cut Algorithm in this case.
4 To be technical, it puts ‘COLR’, ‘ctab’, and ‘pltt’ resources into the resource fork. 

Display Mode One Bit Output Eight Bit Output

Cyan, Magenta, Yellow, or 
Black

PICT containing a dithered repre-
sentation of the chosen component 
of a color separation. 

PICT 2 containing the chosen com-
ponent of a color separation

Grayscale PICT containing a dithered gray-
scale representation of the image.

PICT 2 containing up to 256 shades 
of gray.

Color PICT containing seven images 
which, when displayed or printed, 
yield a color dither of the original 
image.

PICT 2 containing up to 256 colors.
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the compression options.

RIFF

Description

RIFF, or Raster Image File Format, is a format designed by Mark Zimmer of Fractal Software. A RIFF file 
contains a single image of up to 256 grays or colors.

Input

GIFConverter reads the RIFF file as single image in a new document.

Output

Restrictions

GIFConverter only supports the grayscale and “virtual lookup table” (color table based) variants of RIFF. 
It does not support 24-bit RGB, HSL, CMY, and CMYK separation files.

RLE

Description

The RLE (or Run-Length Encoded) format is an early format used on CompuServe. GIFConverter pro-
vides this format for compatibility with small machines that do not have enough memory to read GIF files.

RLE files contain a single image, either 128 x 96 or 256 x 192 pixels.

Input

GIFConverter reads the file into a single image.

Output

GIFConverter chooses the smallest size that will still enclose the document. If the document is larger than 

Display Mode Output

Cyan, Magenta, Yellow, or Black Grayscale document containing the chosen color separation.

Grayscale Up to 256 grays.

Color Up to 256 colors. If the images contain more than 256 colors, the 
best 256 colors are used.
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256 x 192 pixels, then GIFConverter only saves the upper-leftmost area.

GIFConverter saves an RLE file as if it were a small MacPaint file. See that section for details on the way 
images are saved.

Scan Image

Description

The Thunderscan and Thunderworks programs use the Scan Image format to store scanned images. It 
stores a single image with up to 32 gray levels.

Input

GIFConverter reads the file into a single image.

Output

GIFConverter creates a single image containing what you see in a window. This image is written to the 
Scan Image file according to the following restrictions:

Restrictions

Scan Image files contain grayscale data even if One Bit mode is chosen. This allows you to save Scan Im-
age files with grayscale information on black-and-white Macintoshes.

Slide Show

Description

The Slide Show format is not a graphics format, but a special file type where GIFConverter keeps refer-
ences to other files. You can create a Slide Show file by using then New Slide Show… command in the 
File menu.

Display Mode Output

Cyan, Magenta, Yellow, or Black Scan Image file containing the grayscale representation of the 
desired separation.

Grayscale, Color Scan Image file containing the grayscale image.
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Startup Screen

Description

The Startup Screen format derives its name from the StartupScreen file placed in the System Folder and 
displayed when the Macintosh boots. The original StartupScreen file contained a single one-bit image of 
512 x 342 pixels to match the size of the original Macintosh screen. On Macintoshes with Color Quick-
Draw, the file contains a single PICT (or PICT 2) that the Macintosh draws on the screen, adding color and 
the ability to cover larger screens.

GIFConverter can read and write both kinds of Startup Screen. 

Input

When reading a Startup Screen file, GIFConverter follows the following rules:

• If there is a PICT in the file, and GIFConverter is running on a Macintosh with Color QuickDraw, 
read the PICT.

• If there is an original-format StartupScreen in the file, and GIFConverter is running on a Macintosh 
without Color QuickDraw, read the original-format StartupScreen.

• Otherwise, read whatever is in the file. 

See also the discussion of the PICT format above.

Output

GIFConverter writes the StartupScreen file according to the settings in the Options… dialog box (see 
above).

Writing a PICT-style Startup Screen works like the PICT file, above.

Writing an original-format Startup Screen works like the MacPaint format, except that GIFConverter re-
stricts the image size to 512 x 342 pixels. See the MacPaint format for more information.

Options

There are two kinds of Startup Screens. The original Startup Screen was a black-and-white image. Mac-
intosh II computers can read a Startup Screen that  contains a color picture.

Checking the Mac II format option will cause GIFConverter to place a color picture into the Startup-
Screen file. Color Macintoshes (Macintosh II series, Macintosh Quadra series, and the Macintosh SE/30) 
read this data to produce the color picture on the screen.

Unchecking the Mac II format option will cause GIFConverter to create an original-style black-and-white 
Startup Screen. Macintoshes without Color QuickDraw use this data to produce the image on the screen.
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Restrictions

If you read a PICT style Startup Screen on a Macintosh without Color QuickDraw, the results are usually 
rather poor. The picture may be blotchy.

TIFF

Description

TIFF, or Tag Image File Format, is a format developed by Aldus Corporation and Microsoft Corporation 
for storing images.

GIFConverter fully supports TIFF classes G, P, and R of the version 5.0 specification. GIFConverter sup-
ports LZW compression for input only. The TIFF classes are:

Input

GIFConverter reads the image into a new document.

Output

GIFConverter creates a single image containing what you see on the screen, and writes the image to the 
file according to the settings in the File Settings… box.

Options

Turning on Compression… causes TIFF files to be saved with LZW compression. Clicking on Use Pre-
diction can improve the compression, but may not be compatible with some other applications.

The MS-word Fix checkbox causes GIFConverter to allow for errors in the TIFF file support in Microsoft 
Word and other Microsoft products.

Restrictions

GIFConverter’s support of Class G implies support of class B without compression (a grayscale image 
with only two colors is the same as a black and white image).

GIFConverter does not support privately defined compression schemes. These schemes are legal in TIFF, 

Class Description

B Black-and-white images. Compression options include CCITT 1D or PackBits. GIFConverter 
supports only uncompressed class B.

G Grayscale data, 4 or 8 bits per pixel.

P Palette color, up to 256 colors, one to eight bits per pixel.

R RGB full color; 16,277,216 possible colors.
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but not recommended under version 5.0 of TIFF.

Support

Common problems
• If you get system errors (the bomb box) when starting GIFConverter and reading the first images, try 

moving the “GIFConverter Prefs” file to the Trash from the Preferences folder inside the System Fold-
er. Sometimes, if GIFConverter crashes, this file may become corrupt.

• If you get the message that GIFConverter could not open a GIF or TIFF file because of an error in the 
compressed image, then you probably didn’t download the file in binary format. Double-check the 
settings for your terminal program. If you’re using FTP or Kermit to move images around between 
computers, remember to set them to binary mode.

• If GIFConverter won’t open the files you’ve downloaded, they may not have the GIF type. Start GIF-
Converter, then choose Open from the File menu. Open the folder where you put the files, then click 
on the Look Inside All Files (slowest) button.

Reporting Bugs
If you encounter a problem with GIFConverter, send mail to any of the addresses (US Mail or electronic) 
on the cover. Also see the support information in the front of the manual.

When you report a bug, please include the following:

• System configuration (such as: “Macintosh Plus, 4Mb RAM, 80Mb hard disk”)

• If it’s a printer problem, indicate the printer you use (“LaserWriter”) and the version number of the 
printer driver (usually found in the Page Setup dialog box).

• Look in the System Folder and list all files listed as “Startup” or “Control Panel” documents.

• Please indicate what you were trying to do, and how the program failed you. If you get an error mes-
sage or a system error (bomb) box, please indicate the text of the error message as well as any error 
code numbers that appear.

• If you’re having a compatibility problem with sharing files with another application, please indicate 
the name and version of the application, as well as the name of the publisher.

Appendix A: TIFF Compatibility

TIFF files may vary in format, and there is often the chance of incompatibilities between programs. GIF-
Converter conforms to the TIFF classes specification described in Appendix G of the Tag Image File For-
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mat Specification Version 5.0 of 8/8/88.

GIFConverter-generated files contain only one IFD5 (it combines multiple images , which contains the fol-
lowing tags:

GIFConverter generates Class R output if the RGB Output option is selected in the Options… dialog box, 
otherwise it generates Class P. 

If Color is not checked, GIFConverter generates Class G.

GIFConverter-generated TIFF files are always written in Motorola byte ordering6. In conformance to the 
TIFF specifications, GIFConverter can read both Intel and Motorola byte ordering. 

5 Image File Descriptor. An element of a TIFF file that identifies an image in the file and describes its char-
acteristics.
6 The byte ordering determines how multi-byte numbers are stored in the file. If you don’t understand this, 
don’t worry. It’s technical stuff for technical people.

Tag Class G Class P Class R

BitsPerSample 8 8 8,8,8

ColorMap n/a 256 RGB triplets n/a

Compression 1 (no compression, packed data) or 5 (LZW compressed data)

ImageLength Vertical extent of all images

ImageWidth Horizontal extent of all images

PhotometricInterpretation 1 (0 is black, 255 is 
white)

3 (palette color) 2 (RGB triplets)

Predictor 0 (none)

ResolutionUnit 2 (inch)

RowsPerStrip same as ImageLength

SamplesPerPixel 1 1 3

StripByteCounts depends on RowsPerStrip and ImageWidth

StripOffsets one entry

StripsPerImage 1

XResolution 1/72

YResolution 1/72
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Appendix B: File Format References

EPSF
Encapsulated PostScript Files Specification, Version 2.0.
Adobe Systems Incorporated
1585 Charleston Road, PO Box 7900
Mountain View, CA 94039-7900
(415)961-4400

Also available on CompuServe, in the ADOBE forum, library 4, file EPSF.PS.

GIF
Graphics Interchange FormatSM, Version 89a
CompuServe Incorporated
Columbus, Ohio

Available on CompuServe, in the GRAPHSUPPORT forum, library 14, file GIF89A.DOC, GIF89A.SIT 
or GIF89A.ARC. Also available on other major online services.

JPEG
Wallace, Gregory K.  The JPEG Still Picture Compression Standard, Communications of the ACM, April 
1991 (vol. 34 no. 4), pp. 30-44.

The Data Compression Book by Mark Nelson, published by M&T Books (RedwoodCity, CA), 1991, 
ISBN 1-55851-216-0. 

JPEG Still Image Data Compression Standard by William B. Pennebaker and Joan L. Mitchell, published 
by Van Nostrand

Reinhold, 1993, ISBN 0-442-01272-1. This book includes the complete text of the ISO JPEG standards 
(DIS 10918-1 and draft DIS 10918-2).

The JFIF file format specification can be ordered from:
Literature Department
C-Cube Microsystems, Inc.
399A West Trimble Road
San Jose, CA  95131
(408) 944-6300

MacPaint
Macintosh Technical Note #86: MacPaint Document Format
46   GIFConverter



Apple Computer, Inc.
20525 Mariani Avenue, M/S 33G
Cupertino, CA 95014
Attn: APDA
(800)282-2732

This note is available on CompuServe, MACDEV forum, library 7, file TN086.WRT. Macintosh Techni-
cal Notes are also available through other major online information services.

PICT
Inside Macintosh, Volumes I, V, and VI
Published by Addison-Wesley, and available at major bookstores.

Volume V describes using QuickDraw to create a PICT file. The PICT file contains a QuickDraw picture 
in the data fork starting at offset 512. The first 512 bytes of the file should be set to zeroes.

RLE
Standard for RLE files
Chris Hopkins

Available on CompuServe, in the GRAPHSUPPORT forum, library 14, file RLESTD.ASC.

Scan Image
Thunderware
21 Orinda Way
Orinda, CA 94563
(510)254-6581

The Scan Image format was described in early ThunderScan documentation. Thunderware prefers that de-
velopers support TIFF files if they want to work with their scanners.

Startup Screen
Startup Screens contain either a 512 x 342 bitmap in the data fork, or a PICT ID=0 resource in the resource 
fork.

TIFF
Tag Image File Format, Revision 5.0
Developer’s Desk
Aldus Corporation
411 First Ave. South
Suite 200
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Seattle, WA 98104
(206)622-5500

Available on CompuServe, ALDSVC forum, library 10, file TIFF.
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50   GIFConverter


	License Agreement
	Warranty
	Distribution
	Support
	Acknowledgements
	Table of Contents
	About GIFConverter and GIF files
	Setting Up GIFConverter
	System Requirements
	Installing GIFConverter
	License Key
	Configuration File
	Temporary Files

	Working with Documents
	Opening Documents
	Creating Documents
	Saving Documents
	Closing Documents
	Discarding Changes
	The Display
	The Editing Tools
	Selecting Images
	Using the Clipboard
	Moving Images
	Stretching Images
	Scaling Images
	Rotating Images
	Cropping Images
	Changing the Resolution
	Changing the Color Palette
	Reducing the Number of Colors
	Working with Comments
	Undoing the Last Operation
	Memory Usage

	Enhancing Images
	Image Processing Fundamentals
	Image Processing in GIFConverter
	The Image Enhancement Dialog
	Image Enhancement Methods
	Deferred Updates

	Printing Documents
	What you see is what you print
	Print Margins
	ImageWriter
	LaserWriters and other PostScript Printers
	High-Resolution QuickDraw Printers
	Third-Party Printers

	Setting Options
	Remove Unused Colors
	Allow Backgrounding (MultiFinder)
	File Settings

	Working with Slide Shows
	Creating a Slide Show
	Playing a Slide Show

	Working with Other Applications
	Using Multifinder or System 7
	Using the Clipboard
	Placing Postscript halftone images into Microsoft ...
	Using halftone images with QuickDraw printers

	Using a communication program to transfer files
	America Online
	CompuServe Navigator and Information Manager
	MacTerminal 2.0
	Microphone II
	White Knight
	XModem Transfer Tool (Communications Toolbox)
	Other programs
	Online Help

	Supported File Formats
	EPSF
	GIF
	JPEG/JFIF
	MacPaint
	PICT
	RIFF
	RLE
	Scan Image
	Slide Show
	Startup Screen
	TIFF

	Support
	Common problems
	Reporting Bugs

	Appendix A: TIFF Compatibility
	Appendix B: File Format References
	EPSF
	GIF
	JPEG
	MacPaint
	PICT
	RLE
	Scan Image
	Startup Screen
	TIFF

	Index

